Con­nec­tion bet­ween firm­ware – FPGA – PC soft­ware (CBT2 does not mea­su­re)

CBT2 infor­ma­ti­on win­dow

In the info win­dow (> Help > About CAN-Bus Tes­ter 2…) you can see which PC soft­ware you are cur­r­ent­ly working with and which soft­ware is instal­led on the con­nec­ted tes­ter.

Newer pro­gram ver­si­ons of the CBT2 indi­ca­te that soft­ware ver­si­ons do not match. This mes­sa­ge can be hid­den per­ma­nent­ly. (Res­to­re with > Tools > Set­tings > Gene­ral > Dis­play all warning and messages again)

Older ver­si­ons do not show this note (befo­re 4.5.5.0 from 01/​2016).

The pro­blems cau­sed by non-matching soft­ware ver­si­ons are dif­fe­rent. Often the tes­ter is detec­ted, but does not mea­su­re anything or mea­su­res wrong values. The­re­fo­re you should check if your soft­ware ver­si­ons match, espe­cial­ly befo­re sen­ding your device in for repair.

PC-Soft­ware

Release

Firm­ware

FPGA

4.7.8.026.11.201904.1201.68
4.7.7.127.08.201904.1201.68
4.7.7.007.03.201904.1201.68
4.7.6.008.02.201904.1201.68
4.7.5.029.10.201804.1201.68
4.7.4.011.09.201804.1201.68
4.7.3.023.04.201804.1201.68
4.7.2.019.03.201804.1101.68
4.7.1.031.01.201804.1101.67
4.7.0.127.10.201704.1001.67
4.7.0.026.10.201704.1001.67
4.6.7.115.08.201704.0801.67
4.6.7.010.08.201704.0801.67
4.6.6.014.12.201604.0801.67
4.6.5.014.11.201604.0801.67
4.6.4.1 21.10.201604.0701.65
4.6.4.011.10.201604.0701.65
4.6.3.021.09.201604.0701.65
4.6.2.129.08.201604.0701.64
4.6.2.016.08.201604.0701.64
4.6.1.005.08.201604.0701.64
4.6.0.027.05.201604.0701.64
4.5.5.223.02.201604.0701.58
4.5.5.111.02.201604.0701.58
4.5.5.005.01.201604.0701.58
4.5.0.029.10.201504.0701.58
4.4.0.021.04.201504.0601.55
4.3.0.1411.09.201404.0201.44
4.3.0.809.05.201404.0201.44
4.3.0.013.01.201404.0201.44
4.2.0.003.06.201304.0201.41
4.1.0.001.06.201204.0101.41
4.0.224.06.201104.0001.41
4.0.123.06.201104.0001.41
4.0.0.020.05.201104.0001.41
3.1.0.003.05.201002.1501.41
3.0.0.028.05.200902.1201.39
2.1.0.008.04.200802.0401.13
2.0.0.019.11.200702.0001.04
1.3.0.017.09.200700.7701.04